Почему 1С УТ 11 не даёт выбрать типовое соглашение в форме узла обмена с сайтом?

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
#1 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

22.05.2014 20:10

Описание дефекта:
  • Источник дефекта: 1С:Управление торговлей
  • Дефектные версии: некоторые устаревшие версии УТ 11. В частности, версия 11.0.7.21 от 23 марта 2012 года и другие смежные с ней версии.
  • Место дефекта: обмен данными с сайтом, форма узла обмена, вкладка «Обмен заказами», поле «Соглашение»
    Прикрепленное изображение: Форма-узла-обмена.png
  • Проявление дефекта: при нажатии кнопки подбора значения рядом с полем «Соглашение» система открывает справочник для выбора соглашения, однако справочник не содержит имеющиеся в системе типовые соглашения, а перечисляет только индивидуальные соглашения. Таким образом, система не даёт указать типовое соглашене для узла обмена данными.
    Прикрепленное изображение: До-устранения-дефекта.png
  • Последствия дефекта: из-за неуказания типового соглашения для узла обмена данными 1С не передаёт цены интернет-магазину, а также не осуществляет обмен заказами с интернет-магазином.


Способ устранения дефекта:
Лучше всего устранить дефект обновлением 1С:Управление торговли до одной из свежих версий (например, до ветки 1.11, где данного дефекта точно нет).
Однако устранить дефект можно и небольшой правкой дефектной конфигурации 1С:Управление торговлей.
Для этого надо глобальным поиском в конфигураторе найти строку
Если Параметры.ТолькоТиповые Тогда

С этой строки начинается следующий программный код:
Если Параметры.ТолькоТиповые Тогда
    
    Заголовок = НСтр("ru='Типовые соглашения с клиентами'");
    ОбщегоНазначенияУТКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "ТипСоглашения", "Видимость", Ложь);
    ОбщегоНазначенияУТКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "СписокСоздатьИндивидуальноеСоглашение", "Видимость", Ложь);
    ОбщегоНазначенияУТКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "СписокКонтекстноеМенюСоздатьИндивидуальноеСоглашение", "Видимость", Ложь);
Иначе
    ОбщегоНазначенияУТКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "СписокСоздатьТиповоеСоглашение", "Видимость", Ложь);
    ОбщегоНазначенияУТКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "СписокКонтекстноеМенюСоздатьТиповоеСоглашение", "Видимость", Ложь);
КонецЕсли;
//ПВО
Если НЕ Параметры.ТолькоТиповые Тогда
    ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбора(Список.Отбор, "Типовое", Ложь, ВидСравненияКомпоновкиДанных.Равно,, Истина);
КонецЕсли;


Из этого кода надо удалить часть, оставив следующее:
Если Параметры.ТолькоТиповые Тогда    
    Заголовок = НСтр("ru='Типовые соглашения с клиентами'");
    ОбщегоНазначенияУТКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "ТипСоглашения", "Видимость", Ложь);
    ОбщегоНазначенияУТКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "СписокСоздатьИндивидуальноеСоглашение", "Видимость", Ложь);
    ОбщегоНазначенияУТКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы, "СписокКонтекстноеМенюСоздатьИндивидуальноеСоглашение", "Видимость", Ложь);
КонецЕсли;


Теперь форма узла обмена с сайтом должна позволять указывать типовое соглашение:
Прикрепленное изображение: Справочник-соглашений-после-устранения-дефекта.png

#2 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

12.08.2014 16:53

Ещё 2 причины, по которым типовое соглашение будет неприменимо к обмену данными с интернет-магазином:

  • Заполненность графы «Сегмент партнеров» на экране типового соглашения.
    Чтобы типовое соглашение было применимо к обмену данными с интернет-магазином, графа «Сегмент партнеров» типового соглашения обязательно должна оставаться пустой!
  • Выключенность опции «Доступно внешним пользователям» на экране типового соглашения.
    Чтобы типовое соглашение было применимо к обмену данными с интернет-магазином, опция «Доступно внешним пользователям» типового соглашения обязательно должна быть включена!


Оба эти условия изложены в инструкции по настройке типового соглашения для интернет-магазина.

Поделиться темой: