Как заместить устаревший модуль `mcrypt` для PHP 7.2 ради Magento 1?

Magento 2: модули и услуги
magereport.com: составление перечня необходимых для установки заплаток SUPEE
#1 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8989
  • Регистрация: 20.02.2010

02.01.2018 11:32

PHP 7.2 не содержит устаревший модуль mcrypt, однако настолько же устаревшая Magento 1 требует его.
Что же делать?

Debian
Для Debian я рекомендую устанавливать `mcrypt` через pecl:

pecl install mcrypt-snapshot


Windows
В среде Windows рекомендую использовать библиотеку phpseclib/mcrypt_compat.
Я написал инструкцию по добавлению этой библиотеки к Magento 1.

Поделиться темой: