Как устранить сбой «Package <название модуля> requires PHP version <...>» при установке модуля из Magento Connect при использовании PHP 7?

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
#1 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

16.11.2016 12:39

При установке модуля из Magento Connect посредством веб-интерфейса при использовании PHP 7 возможен сбой:

CONNECT ERROR: Package <название модуля>: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.13-1~dotdeb+8.1

Прикрепленное изображение: 02.png

В случае такого сбоя устанавливайте модуль с командной строки с ключом force:

./mage install http://connect20.magentocommerce.com/community [название установочного пакета]  --force


Например:
./mage install http://connect20.magentocommerce.com/community ASchroder_SMTPPro --force


При этом установщик всё равно предупредит о неподдерживаемой версии интерпретатора PHP, но благодаря ключу --force модуль установит:
Прикрепленное изображение: 06.png

#2 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

16.11.2016 13:02

Как устранить сбой «./mage: Permission denied» при установке модуля из Magento Connect с командной строки?

Поделиться темой: