Your web server is configured incorrectly

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
#1 Dima
  • ворует чужие книги и выдаёт за свои
  • Группа: Заблокирован
  • Сообщений: 128
  • Регистрация: 05.04.2011

21.09.2011 00:46

Ваш веб-сервер настроен неправильно.
В результате, конфигурационные файлы с конфиденциальной информацией доступны извне. Пожалуйста, свяжитесь с вашим хостинг-провайдера.
У меня вопрос что это такое?
На сервере стоит пароль, база данных тоже с паролям, в чем причина?
На какие файлы поставить только чтение или установочные файлы удалить какие только?
:blink:
Заранее благодарен!

#2 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

21.09.2011 00:51

Кто вам прислал данное сообщение?

#3 Dima
  • ворует чужие книги и выдаёт за свои
  • Группа: Заблокирован
  • Сообщений: 128
  • Регистрация: 05.04.2011

21.09.2011 01:02

В Magento написано сверху и лапочка горит
Прикрепленное изображение: Безопасность.jpg

#4 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

21.09.2011 01:46

Каково оригинальное англоязычное сообщение?

#5 Dima
  • ворует чужие книги и выдаёт за свои
  • Группа: Заблокирован
  • Сообщений: 128
  • Регистрация: 05.04.2011

21.09.2011 01:51

Вот оно англоязычное
Your web server is configured incorrectly. As a result, configuration files with sensitive information are accessible from the outside. Please contact your hosting provider.

Прикрепленное изображение: Безопасность 2.jpg

#6 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

21.09.2011 01:55

Данное сообщение означает, что файл app/etc/local.xml на вашем сайте доступен извне по протоколу HTTP без авторизации.

#7 Dima
  • ворует чужие книги и выдаёт за свои
  • Группа: Заблокирован
  • Сообщений: 128
  • Регистрация: 05.04.2011

21.09.2011 01:59

А как мне его закрыть, или какие правила ему назначить?

#8 Dima
  • ворует чужие книги и выдаёт за свои
  • Группа: Заблокирован
  • Сообщений: 128
  • Регистрация: 05.04.2011

28.09.2011 02:37

Это предупреждение выходит в связи того что не настроен нормально mod_rewrite и файлы .htaccess не работают.
Для того, чтобы файлы .htaccess можно было использовать, необходимы соответствующие настройки главного конфигурационного файла httpd.conf, где должны быть прописаны директивы, которые разрешат файлу .htaccess переопределять конфигурацию Web-сервера в каталоге. Список этих директив задаётся директивой AllowOverride.

Директива AllowOverride может включать в себя одну из следующих директив или их комбинацию: AuthConfig, FileInfo, Indexes, Limit, Options, All, None

Для того чтобы дать директивам файлов .htaccess максимальные права на изменения директив, значение директивы AllowOverride в файле httpd.conf должно быть равно All. Оно является значением по умолчанию.
AllowOverride All


Запретить переопределение любых директив в конфигурационных файлах .htaccess можно при помощи значения None:
AllowOverride None
Решение проблемы!! :D
Что бы работали файлы .htaccess magento\.htaccess
Открываем файл ....\Apache2\conf\httpd.conf
Найдите данный блок:
<Directory />
   Options FollowSymLinks
   AllowOverride None
   Order deny,allow
   Deny from all
</Directory>

И замените его на нижеследующий:
<Directory />
   Options Includes Indexes FollowSymLinks
   AllowOverride All
   Allow from all
</Directory>

Установите такие параметры дальше остальное в блоках
AllowOverride All

:D
<Directory "C:\zs\Apache2/cgi-bin">   #Здесь ваш адрес должен быть
    AllowOverride All
    Options None
    Order allow,deny
    Allow from all
</Directory>

Перезапустите Apache (Restart Apache)
Результат
http://127.0.0.1/magento/app/etc/local.xml

Посетители не могут получить доступ к local.xml
Прикрепленное изображение: Безопасность решение.jpg
:rolleyes:

Поделиться темой: