extension "curl" must be loaded

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
#1 Danila_Master
  • Группа: Пользователь
  • Сообщений: 29
  • Регистрация: 04.04.2011

04.04.2011 16:46

Поставил PHP5 последней версии. Инсталлер Magento ругается.
o PHP extension "pdo_mysql" must be loaded.
o PHP extension "curl" must be loaded.
o PHP extension "gd" must be loaded.
Как это подключить?

в файле php.ini есть строчки вида
;extension=php_pdo_mysql.dll
убрал ";", скопировал в windows, перезапустил apache, все равно выдает ошибки.
P.S. версия Magento 1.4.1.0

#2 Danila_Master
  • Группа: Пользователь
  • Сообщений: 29
  • Регистрация: 04.04.2011

04.04.2011 17:32

Дописал в php.ini нужную extension_dir. Две ошибки прошли, но все ругается PHP extension "curl" must be loaded. хотя она есть в папке.

#3 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

04.04.2011 17:43

Подтверждает ли интерпретатор PHP на экране phpinfo факт установки библиотеки curl?

#4 Danila_Master
  • Группа: Пользователь
  • Сообщений: 29
  • Регистрация: 04.04.2011

04.04.2011 17:45

Нашел ответ на страничке
http://omsk777.ru/php_curl.html


Цитата

кроме этого в папке с модулями для Win32 - это папка, где лежат основные файлы с расширением .dll (например, win/sistem/drivers/ или windows/sistem32/ или др.) должны быть два дополнительных файла libeay32.dll и ssleay32.dll. Если их там нет, то самостоятельно запишите их туда из папки dlls, которая находится рядом с папкой extensions.


#5 fatima
  • Группа: Заблокирован
  • Сообщений: 3
  • Регистрация: 01.10.2011

01.10.2011 20:26

Здравствуйте! вот у меня при установке скрипта, тоже такая же ошибка, но я на сраничке которую вы дали нужнлй инфы к сожалению не нашла. я вообщем то новичек совсем не понимаю даже что там написано. попробывала установить предложенную там библиотеку при перезапуске денвера появилась ошибка не найден php4ts, правильно у меня 5, а те библиотеки которые предложены видимо для 4 подходят. PHP extension "curl" must be loaded - ошибка не пропадает причем при установке denwera2 (сейчас третий поставила) еще и mcrypt просил. на инфо страничке в 3 денвере mcrypt есть, а curl нет, версия magento-1.6.0.0 (с 5 тоже самое), в php.ini пробывала раскоментить эту строчку, не помогло только при запуске php.exe и php-cgi.exe стало выдавать ошибку, я так поняла что предупреждение о том что раскоментировано но не присутствует
==========
вообщем 4 день не могу установить скрипт на денвер, чем сможете помочь?

#6 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

01.10.2011 22:14

Перед тем, как начинать разрабатывать магазины на Magento, необходимо обладать знаниями по вспомогательным технологиям: веб-сервер, язык и интерпретатор PHP, язык разметки HTML и т.п.
Если установка расширений PHP вызывает у вас трудности - начните с азов: прочитайте руководство администратора по интерпретатору PHP, прочитайте про устройство php.ini, прочитайте про журнал ошибок интерпретатора и другие способы диагностики интерпретатора.
Другой, более которкий путь - установить вместо Денвера веб-сервер, где требуемые расширения PHP уже присутствуют: например, Zend Server.
Это поможет вам обойти эту конкретную проблему, но, в целом, сохранится вероятность, что вы точно также споткнётесь на следующей, поэтому систематического изучения вспомогательных технологий вам не избежать.

#7 fatima
  • Группа: Заблокирован
  • Сообщений: 3
  • Регистрация: 01.10.2011

02.10.2011 20:47

я имею два сайта на cms joomla и cms Wordpress, как вы понимаете все это разрабатывалосль на denwer, подобных ошибок у меня не возникало, это конечно разные вещи magento, joomla и wordpress (и еще куча разных скриптов которые я без проблем устанавливала на denwer), но я деkаю, точнее пытаюсь научиться работать с magento по видеокурсу и дело в том что, так на всякий случай, я устанавливала версии как сервера так и скрипта именно такие как в курсе, там нет этих ошибок. кстати как исправить многие ошибки на denwer я знаю, но вот с этой сталкиваюсь в первые, и поэтому обратилась за помощью сюда.
но если вы не можете помочь то к чему нравоучения. просто можно сказать что вы не в курсе и небыло у вас подобных ошибок или указать конкретно где понятным языком написано как их исправить. или просто разъяснить.
или это я вообще не по aдресу обратилась?

#8 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

02.10.2011 20:52

Не по адресу.
Вам с вашим уровнем квалификации надо платить разработчикам либо начинать обучение с азов.
Перепрыгнуть ступении обучения и сразу начинать работать с Magento не получится.

#9 Сенсей
  • Группа: Пользователь
  • Сообщений: 1
  • Регистрация: 02.10.2011

02.10.2011 21:46

Просмотр сообщенияfatima (01.10.2011 20:26) писал:

Здравствуйте! вот у меня при установке скрипта, тоже такая же ошибка, но я на сраничке которую вы дали нужнлй инфы к сожалению не нашла. я вообщем то новичек совсем не понимаю даже что там написано. попробывала установить предложенную там библиотеку при перезапуске денвера появилась ошибка не найден php4ts, правильно у меня 5, а те библиотеки которые предложены видимо для 4 подходят. PHP extension "curl" must be loaded - ошибка не пропадает причем при установке denwera2 (сейчас третий поставила) еще и mcrypt просил. на инфо страничке в 3 денвере mcrypt есть, а curl нет, версия magento-1.6.0.0 (с 5 тоже самое), в php.ini пробывала раскоментить эту строчку, не помогло только при запуске php.exe и php-cgi.exe стало выдавать ошибку, я так поняла что предупреждение о том что раскоментировано но не присутствует
==========
вообщем 4 день не могу установить скрипт на денвер, чем сможете помочь?


У меня была такая же проблема.

1. Вместо Денвера установил xampp - ссылка.

2. Залил дистрибутив magento в папку xampp\htdocs\magento\

3. Запустил xampp (в панели нажал Start напротив Apache и MySQL)

4. Началась установка magento, однако и там возникла 1 ошибка (в Денвере выдавало 2)

5. Как и написано над вашим постом скопировал 2 файла d:\xampp\php\libeay32.dll и d:\xampp\php\ssleay32.dll в папку Windows\system32

и всё заработало!! удачи ;)

#10 firstday
  • Группа: Пользователь
  • Сообщений: 1
  • Регистрация: 09.11.2011

09.11.2011 11:06

Столкнулся с похожей проблемой и тоже на Денвере: у меня не хватало модулей mcrypt и curl.
Решил следующим образом:
1. скачал и установил Денвер с PHP 5.3 (при скачивании с оф. сайта Денвера, есть возможность выбора версии PHP)
2. скачал и установил модули расширения PHP (http://www.denwer.ru...kages/php5.html)
3. в файле php.ini (\usr\local\php5\php.ini) раскомментировал строки: extension=php_curl.dll и extension=php_mcrypt.dll
4. перезапустил Денвер.

Все работает.

Поделиться темой: