Ves Super Store (ThemeForest 8002349): удаление устаревшей и конфликтующей версии jQuery

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
#1 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

20.08.2015 18:15

Оформительская тема Ves Super Store (ThemeForest 8002349) загружает на страныцы магазина устаревшую и конфликтующую с Российской сборкой Magento версию библиотеки jQuery.
Как правило, Российская сборка Magento способна устранять такие проблемы автоматически, но в данном случае это невозможно, потому что Ves Super Store (ThemeForest 8002349) загружает скрипты очень нестандартным способом.
Устранение проблемы надо внести 2 правки в файл app/code/community/Ves/Tempcp/Helper/Framework.php

  • Примерная строка: 640
    Удалить следующий код:
    $tmp_assets["js/venustheme/ves_tempcp/jquery/jquery.min.js"] = array("type"=> "js",
    "name" => "venustheme/ves_tempcp/jquery/jquery.min.js",
    "params" => "",
    "if" => "",
    "cond" => "");
    
    $tmp_assets["js/venustheme/ves_tempcp/jquery/conflict.js"] = array("type"=> "js",
    "name" => "venustheme/ves_tempcp/jquery/conflict.js",
    "params" => "",
    "if" => "",
    "cond" => "");

  • Примерная строка: 671
    Удалить следующий код:
    elseif(strpos($nametmp, "jquery.js") || strpos($nametmp, "jquery.min.js") || strpos($nametmp, "jquery-1.7.1.min.js") || strpos($nametmp, "jquery-1.8.0.min.js")){
        unset($tmp_assets[$key]);
    } 


Поделиться темой: