Warning: realpath() [function.realpath]: SAFE MODE Restriction in effect

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
#1 woric18
  • Группа: Пользователь
  • Сообщений: 13
  • Регистрация: 23.11.2010

23.11.2010 08:09

После установики, проблема на любую страничку.

Пожалуйста помогите решит.


Warning: realpath() [function.realpath]: SAFE MODE Restriction in effect.  The script whose uid/gid is 1194/33 is not allowed to access /tmp owned by uid/gid 0/0  in /users/subreg/1760/sertifikaty.eu/lib/Zend/Cache/Backend.php on line 171

#0 [internal function]: mageCoreErrorHandler(2, 'realpath() [getTmpDir()
#3 /users/subreg/1760/sertifikaty.eu/lib/Zend/Cache.php(152): Zend_Cache_Backend_File->__construct(Array)
#4 /users/subreg/1760/sertifikaty.eu/lib/Zend/Cache.php(93): Zend_Cache::_makeBackend('File', Array, false, false)
#5 /users/subreg/1760/sertifikaty.eu/lib/Zend/Locale/Data.php(307): Zend_Cache::factory('Core', 'File', Array, Array)
#6 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Html/Calendar.php(42): Zend_Locale_Data::getList('en_US', 'days')
#7 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Abstract.php(753): Mage_Core_Block_Html_Calendar->_toHtml()
#8 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Abstract.php(520): Mage_Core_Block_Abstract->toHtml()
#9 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Abstract.php(471): Mage_Core_Block_Abstract->_getChildHtml('calendar', true)
#10 /users/subreg/1760/sertifikaty.eu/app/design/adminhtml/default/default/template/page/head.phtml(34): Mage_Core_Block_Abstract->getChildHtml('calendar')
#11 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Template.php(212): include('/users/subreg/1...')
#12 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Template.php(239): Mage_Core_Block_Template->fetchView('adminhtml/defau...')
#13 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Template.php(253): Mage_Core_Block_Template->renderView()
#14 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Abstract.php(753): Mage_Core_Block_Template->_toHtml()
#15 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Abstract.php(520): Mage_Core_Block_Abstract->toHtml()
#16 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Abstract.php(471): Mage_Core_Block_Abstract->_getChildHtml('head', true)
#17 /users/subreg/1760/sertifikaty.eu/app/design/adminhtml/default/default/template/page.phtml(43): Mage_Core_Block_Abstract->getChildHtml('head')
#18 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Template.php(212): include('/users/subreg/1...')
#19 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Template.php(239): Mage_Core_Block_Template->fetchView('adminhtml/defau...')
#20 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Template.php(253): Mage_Core_Block_Template->renderView()
#21 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Adminhtml/Block/Template.php(81): Mage_Core_Block_Template->_toHtml()
#22 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Block/Abstract.php(753): Mage_Adminhtml_Block_Template->_toHtml()
#23 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Model/Layout.php(529): Mage_Core_Block_Abstract->toHtml()
#24 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Controller/Varien/Action.php(389): Mage_Core_Model_Layout->getOutput()
#25 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Adminhtml/controllers/NotificationController.php(45): Mage_Core_Controller_Varien_Action->renderLayout()
#26 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Adminhtml_NotificationController->indexAction()
#27 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('index')
#28 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Controller/Varien/Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#29 /users/subreg/1760/sertifikaty.eu/app/code/core/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch()
#30 /users/subreg/1760/sertifikaty.eu/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#31 /users/subreg/1760/sertifikaty.eu/index.php(80): Mage::run('', 'store')
#32 {main}


#2 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

23.11.2010 08:42

Для решения проблемы попробуйте отключить режим интерпретатора PHP под названием safe_mode.

Этот режим можно отключить в php.ini:
safe_mode 0


Можно также попробовать отключить его через .htaccess:
php_value safe_mode "0"


#3 woric18
  • Группа: Пользователь
  • Сообщений: 13
  • Регистрация: 23.11.2010

23.11.2010 09:38

Прописал в симпл что в корневом safe_mode 0 но не работает тогда я добавил в оба .htaccess и по прежнему тоже ошибка.

Вспомнил, пишет:

There has been an error processing your request
Exception printing is disabled by default for security reasons.

Error log record number: ###############


#4 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

23.11.2010 09:46

Как посмотреть отчёт об ошибке в Magento

#5 woric18
  • Группа: Пользователь
  • Сообщений: 13
  • Регистрация: 23.11.2010

23.11.2010 09:55

То наверху по этому же схема, лог с этого.

Просто читать не могу в ошибке.

#6 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

23.11.2010 09:56

Дайте ссылку на результат функции phpinfo в корне Magento.

#7 woric18
  • Группа: Пользователь
  • Сообщений: 13
  • Регистрация: 23.11.2010

23.11.2010 10:07

Цитата

Дайте ссылку на результат функции phpinfo в корне Magento.

phpinfo

#8 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

23.11.2010 10:13

phpinfo говорит, что у вас режим safe_mode не отключен.
Отключение через .htaccess работает не всегда, потому что настройки Apache могут запрещать пользователям менять настройки интерпретатора PHP через .htaccess.
Вам нужно открыть файл /etc/php5/apache2/php.ini и отключить safe_mode именно там, а затем перезапустить Apache.

#9 woric18
  • Группа: Пользователь
  • Сообщений: 13
  • Регистрация: 23.11.2010

23.11.2010 10:31

Спасибо что панели в чем проблема, хостинг не поменяет мне сафемод, так что я погорел.

#10 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

23.11.2010 11:28

Да, выключенный режим safe_mode - официальное требование Magento, об этом сказано на их сайте.

#11 woric18
  • Группа: Пользователь
  • Сообщений: 13
  • Регистрация: 23.11.2010

23.11.2010 12:12

Очень вам благодарен сударь Дмитрий Федюк.

Поделиться темой: