CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in Curl.php on line 529

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
#1 Иван Шиленков
  • Группа: Клиент
  • Сообщений: 28
  • Регистрация: 24.09.2014

30.09.2014 03:25

Добрый день, при установке расширения через Magento Connect получаю ошибку, например:
community/AW_Blog: Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /var/www/mirindadomo/data/www/test.mirindadomo.ru/downloader/lib/Mage/HTTP/Client/Curl.php on line 529


помогите, пожалуйста, решить проблему.

PHP
Directive | Local Value |Master Value
open_basedir | /var/www/mirindadomo/data:. | no value

safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value

#2 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

30.09.2014 03:52

Период бесплатной техподдержки закончился.

#3 Иван Шиленков
  • Группа: Клиент
  • Сообщений: 28
  • Регистрация: 24.09.2014

30.09.2014 15:13

Закомментировал строку #529 @, проблема пропала. Прошу проверить, чтобы не было выпадения др. функций:
    /**
     * Set curl option directly
     *
     * @param string $name
     * @param string $value
     */
    protected function curlOption($name, $value)
    {
        @curl_setopt($this->_ch, $name, $value);
    }

Прикрепленный файл  Curl.php (12.65К)
Количество загрузок:: 125

#4 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

30.09.2014 15:17

Сочетать некачественные технические решения с просьбами не нужно.
Согласно официальным требованиям Magento, опция safe_mode интерпретатора PHP должна быть отключена: http://magento.com/r...em-requirements

#5 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

30.09.2014 15:20

На значение опции open_basedir интерпретатора PHP Magento никаких требований не накладывает, но устанавливаемый Вами модуль AW Blog, который стал причиной сбоя, похоже, требует, чтобы эта опция также была отключена. Рекомендую ее отключить.

#6 Иван Шиленков
  • Группа: Клиент
  • Сообщений: 28
  • Регистрация: 24.09.2014

30.09.2014 17:15

Цитата

но устанавливаемый Вами модуль AW Blog, который стал причиной сбоя

все модули отказались устанавливаться, пробовал 3 шт., с одинаковой ошибкой. Ранее такого не было.

Решение:
1. Строку раскомментировал, вернул изначальное состояние.
2. Обратился в тех.поддержку хостинга -> отключили open_basedir (safe_mode был отключен по умолчанию)
всё работает!

Поделиться темой: