You have the non-thread-safe version of the Windows loader but you need the thread-safe one

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
#1 Юрий Буяло
  • Группа: Пользователь
  • Сообщений: 0
  • Регистрация: 13.07.2012

16.07.2012 15:23

Пытался установить русскую локализацию Magento на Денвер. При попытке установить ioncube постоянно выдает какие-то ошибки: то ему кажется что он два раза подключен в php.ini потом когда верхнюю строчку убираю при перезапуске Денвера выдает ошибку: "syntax error, unexpected BOOL_FALSE in Z:\usr\local\php5php.ini on line 1058" к примеру, а вот что пишет установщик ioncube после всех манипуляций: "You have the non-thread-safe version of the Windows loader but you need the thread-safe one."... И никак не фиксится и инструкций по исправлению не нашел. А php.ini перезаписал на тот который предложил мне мастер установки.

Windows 7 x64

Короче у меня руки опустились буду пока без русской локалки тестить.

P.S. Если кто-то вдруг подскажет решение, буду очень признателен.

#2 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

16.07.2012 15:28

На общедоступный сервер я устанавливаю Росийскую сборку Magento бесплатно.

#3 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

16.07.2012 15:42

Конкретно данное сообщение означает, что вы установили не ту версию ionCube Loader.
ionCube говорит вам, что вам нужна версия, скопилированная в специальном режиме для безопастности параллельного выполнения нескольких потоков. На сайте ionCube это та версия, название которой не содержит суффикса Non-TS (non-thread-safe).

Поделиться темой: