Проблемы с rewrite на сервере

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
#1 IgorN
  • Группа: Пользователь
  • Сообщений: 293
  • Регистрация: 09.03.2011

14.10.2011 10:02

Добрый день!

Magento 1.3.4
Под виндой на моей машине все работает проблем нет.
Вчера перенесли(с моей машины) проект на сервер с линуксом (убунту 10.09) apache + nginx
Проект и базу скопировали полностью.
С хостами все ок (не localhost).
Проблема
Захожу в админку ввожу логин и пароль идет редирект на index.php/admin/dashboard/index/key/6b6756a1065af616370776ff1ea165b6/
и вместо админки вижу 404 страницу с последующим редиректом на главную.
Сам сайт работает отлично, по каталогам бегаю, в менюшки захожу, все ок.
Так же у меня это мультисайт
Мультисайт находится по адресу host.home/pro
При попытке зайти та же байда что с админкой, сразу редирект на главную.

Кэш чистил.
Логи и репорты смотрел - пусто.
В index.php

error_reporting((E_ALL | E_STRICT) & ~E_DEPRECATED);

Mage::setIsDeveloperMode(true);

ini_set('display_errors', 'on');
ini_set('display_startup_errors', 'on');
ini_set('track_errors', 'on');


Версия пхп и там и там 5.3.4

Отлаживать на серваке проблематично. Есть доступ только на просмотр файлов по ssh.

Куда копать? Буду благодарен за любые наводки.

#2 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

14.10.2011 10:36

Когда устанавливаете Magento не в корневую папку - надо изменить соответствующим образом файл .htaccess.
Также не забывайте менять корневой адрес сайта в core_config_data.
Также надо очищать кеш.

#3 IgorN
  • Группа: Пользователь
  • Сообщений: 293
  • Регистрация: 09.03.2011

14.10.2011 10:42

Просмотр сообщенияДмитрий Федюк (14.10.2011 10:36) писал:

Также не забывайте менять корневой адрес сайта в core_config_data.
Также надо очищать кеш.

Сделал.

Цитата

Когда устанавливаете Magento не в корневую папку - надо изменить соответствующим образом файл .htaccess

Локальный конфиг на моей машине
<VirtualHost *:80>
       ServerAdmin webmaster@localhost
       ServerName  host.home
       ServerAlias *.host.home
       DocumentRoot 'G:\Projects\Company\MyProject'
       DirectoryIndex index.php
       <Directory 'G:\Projects\Company\MyProject'>
               Options FollowSymLinks MultiViews
               AllowOverride all
               Order allow,deny
       Allow from all
       </Directory>
</VirtualHost>


На серваке отличается только путь /home/igor/projects/MyProject -примерно такой
Т.е. вроде нечего не изменилось...

#4 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

14.10.2011 10:45

*.conf и .htaccess - не совсем то же самое.

#5 IgorN
  • Группа: Пользователь
  • Сообщений: 293
  • Регистрация: 09.03.2011

14.10.2011 10:50

Я знаю.

conf почти идентичный ,в нем вроде проблемы нет.
.htaccess я вообще не трогал при установке на локальную машину и на серваке его тоже не трогали.
Может я что то проглядел, ткни носом на что обратить внимание :)

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /

############################################
## workaround for HTTP authorization
## in CGI environment

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    RewriteRule .* index.php [L]

</IfModule>


Точно такой же htaccess и для мультисайта в host.home/pro

#6 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8884
  • Регистрация: 20.02.2010

14.10.2011 10:52

Обратите внимание на комментарий рядом с директивой RewriteBase.

#7 IgorN
  • Группа: Пользователь
  • Сообщений: 293
  • Регистрация: 09.03.2011

14.10.2011 10:55

Ок, попробуем.

Хотя всеравно не понятно почему локально все пашет.

Спасибо! Вечером отпишусь.

#8 IgorN
  • Группа: Пользователь
  • Сообщений: 293
  • Регистрация: 09.03.2011

14.10.2011 20:49

Проблема была в nginx. Как только его отключили все заработало.Игра с RewriteBase / пользы не принесла.
Ниже привожу код конфига, может кто поймет в чем дело.
server {
    listen       80;
    server_name mysite.home www.mysite.home *.mysite.home;
    
    charset utf-8;

    # Main location
    location / {
        proxy_pass         http://127.0.0.1:8080/;
        proxy_redirect     off;

        proxy_set_header   Host             $host;
        proxy_set_header   X-Real-IP        $remote_addr;
        proxy_set_header   X-Forwarded-For  $proxy_add_x_forwarded_for;

        client_max_body_size       100m;
        client_body_buffer_size    128k;

        proxy_connect_timeout      90;
        proxy_send_timeout         90;
        proxy_read_timeout         90;

        proxy_buffer_size          4k;
        proxy_buffers              4 32k;
        proxy_busy_buffers_size    64k;
        proxy_temp_file_write_size 64k;
        
        set $no_gzip 0;
        if ($http_user_agent ~ "MSIE [4-6]\.|Safari|Konqueror") {
            set $no_gzip 1;
        }
        if ($http_accept_encoding !~ "gzip") {
            set $no_gzip 1;
        }
    }

    # Static files location
    location ~* ^.+\.(jpg|jpeg|gif|png|ico|css|zip|tgz|rar|bz2|doc|xls|pdf|ppt|txt|tar|wav|bmp|rtf|js)$ { 
        expires max;
        root "/home/igor/MySite";
    }
    
    location ~ /\.ht {
            deny  all;
    }
}


Поделиться темой: