Не загружаются фотографии товара - Upload HTTP Error

[10 ноября 2016 г.]    Российская сборка Magento 2.49.12
Magento 2: модули и услуги
  • Тема закрыта
#1 Profix
  • Группа: Пользователь
  • Сообщений: 11
  • Регистрация: 06.02.2011

22.07.2011 12:01

Добрый день.

Столкнулся с очередной ошибкой или багом.

Чистый Magento 1.5.1 с демо товарами. При добавлении фотографий в товар, после нажатия кнопки "upload files" появляется "бегунок", показывающий что изображение загружается. После этого бегунок краснеет и появляется надпись Upload HTTP Error. Если нажать "Сохранить товар", то фотографии, разумеется, не будет.

Куда копать, подскажите, пожалуйста? Последний Фаерфокс, плеер последний Flash 10. Пробовал Opera - тоже самое. Magento установлен локально на Denwer, поэтому проблем с правами на папки быть не может.

Могу привести листинг php.ini или httpd.

В htaccess по советам в интернете пробовал прописать, не помогло:

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

#2 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

22.07.2011 12:04

Проблемы с правами могут быть и в Windows.
Убедитесь, что папка media и всё её содержимое доступны учётной записи веб-сервера для записи.

#3 Profix
  • Группа: Пользователь
  • Сообщений: 11
  • Регистрация: 06.02.2011

22.07.2011 12:07

Дмитрий, извините, о какой именно учетной записи идет речь? Она прописана в Апаче?

#4 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

22.07.2011 12:11

Откройте окно Properties для папки media.
Убедитесь, что на основной вкладке убран флаг Read Only.
Перейдите на вкладку Security.
Там перечислены все учётные записи операционной системы.
Убедитесь, что все они имеют права на запись в папку media.
Когда меняете права, включайте опцию рекурсивной смены.

#5 Profix
  • Группа: Пользователь
  • Сообщений: 11
  • Регистрация: 06.02.2011

24.07.2011 17:04

Дмитрий, действительно, проблема была в настройке Безопасности в windows 7.

Спасибо!!! :)

#6 Андрей Инютин
  • Группа: Пользователь
  • Сообщений: 3
  • Регистрация: 20.08.2011

26.08.2011 14:56

Просмотр сообщенияProfix (24.07.2011 17:04) писал:

Дмитрий, действительно, проблема была в настройке Безопасности в windows 7.

Спасибо!!! :)


У меня та же проблема на Windows 7.
Измучил всю папку media.

Подскажите поподробней что делать? что именно надо настроить в безопасности windows7?

Причем фотографии в \www\media\tmp\catalog\product попадают...

Заранее спасибо.

#7 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

26.08.2011 22:52

Смотрите мой ответ на 2 сообщения выше.

#8 Андрей Инютин
  • Группа: Пользователь
  • Сообщений: 3
  • Регистрация: 20.08.2011

27.08.2011 03:35

Просмотр сообщенияДмитрий Федюк (26.08.2011 22:52) писал:

Смотрите мой ответ на 2 сообщения выше.


Дмитрий, я снял "только для чтения" с папки media, denwer у меня запускается как программа(не как служба), права всем учеткам дал к папке и подпапкам media.

установлена windows7 Ultimate RUS, в отличии от описанной проблемы у меня надписи "Upload HTTP Error" не появляется - просто краснеет название товара - может проблема в чем нибудь другом?

Прикрепленные изображения

  • Прикрепленное изображение: ошибка.jpg


#9 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

27.08.2011 06:04

Причиной дефекта в вашем конкретном случае является сама Magento 1.6.0.0.
Эта версия содержит данный дефект с загрузкой картинок.
Для новых магазинов используйте пока Magento 1.5.1.0.
Вообще, как правило, версии Magento, заканчивающиеся на 0.0 (1.4.0.0, 1.5.0.0, 1.6.0.0) содержат критические дефекты, использовать их на промышленных сайтах крайне не рекомендую.
Для перехода на ветку 1.6 подождите выхода 1.6.0.1, а пока используйте стабильную версию ветки 1.5 - 1.5.1.0

#10 Андрей Инютин
  • Группа: Пользователь
  • Сообщений: 3
  • Регистрация: 20.08.2011

27.08.2011 08:39

Спасибо огромное..

Установил 1.5.1.0, убрал "только для чтения" и выставил все права для "Всех" в папке media - все заработало...

#11 alex_magento
  • Группа: Пользователь
  • Сообщений: 60
  • Регистрация: 09.01.2012

17.01.2012 14:18

Добрый день! У меня такая проблема. У меня 2 сайта на сервере. Стоят версия мадженты 1.5 и 1.6. Вот где 1.5 версия там у пользователей mac os почему то возникает ошибка при закачивании фото, а на версии 1.6 таких проблем нет. С чем это связано? Спасибо!

#12 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

17.01.2012 14:19

Прикрепите снимок экрана с диагностическим сообщением системы.

#13 alex_magento
  • Группа: Пользователь
  • Сообщений: 60
  • Регистрация: 09.01.2012

17.01.2012 14:48

Вот.

Прикрепленные изображения

  • Прикрепленное изображение: zzzzzzzzzzzzzzzzzzzzzz.jpg


#14 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

17.01.2012 16:49

Некоторые версии Magento действительно дефектно выпляют загрузку картинок на сервер.

У вас имеется очевидный путь устрананения сбоя — обновить Magento.
Можно попробовать также точечно обновить файлы загрузчика — но для этого нужна не менее высокая квалификация исполнителя, чем при обновлении всей Magento.
Третий путь — попробовать загружать картинки не посредством Safari, а посредством альтернативного браузера: например, Firefox для Mac OS X.

#15 alex_magento
  • Группа: Пользователь
  • Сообщений: 60
  • Регистрация: 09.01.2012

17.01.2012 18:03

Да на всех браузерах такая же ошибка. Спасибо в любом случае!

#16 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

17.01.2012 18:08

Ещё на всякий случай проверьте, что на проблемном компьютере правильно настроено время.
Хотя проблема, скорей всего, именно в программном коде.

#17 alex_magento
  • Группа: Пользователь
  • Сообщений: 60
  • Регистрация: 09.01.2012

17.01.2012 18:42

Просто читал на форуме что возможно из-за флэш плеера. Было порекомендовано установить No Flash Image Uploader. Я его установил. Но у меня почему то исчезла кнопка выбрать файл. Дело в том что при установки темы я загружал базу которая шла вместе с темой. Как вы думаете это как-то могло помочь?

#18 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

17.01.2012 18:44

О сторонних модулях лучше узнавать у их разработчиков.
Этот форум предназначен для сопровождения стандартных модулей и Российской сборки.

#19 alex_magento
  • Группа: Пользователь
  • Сообщений: 60
  • Регистрация: 09.01.2012

17.01.2012 18:48

Хорошо, прошу прощения. Так из-за флэш плеера может быть проблема?

#20 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

17.01.2012 18:50

Да, проблема может именно в загрузчике.

#21 Жулдыз Токсанбаева
  • Группа: Пользователь
  • Сообщений: 2
  • Регистрация: 21.07.2014

21.07.2014 13:24

дд. версия Российская сборка Magento 2.20.5 (1.7.0.2), раньше с загрузкой изображений проблем не было. вот буквально неделю как изображения перестали прикрепляться.

Прикрепленные изображения

  • Прикрепленное изображение: прин.jpg


#22 Дмитрий Федюк
  • Администратор
  • Иконка
  • Группа: Администратор
  • Сообщений: 8885
  • Регистрация: 20.02.2010

21.07.2014 13:40

Нарушение пункта 21 правил публикации сообщений и пунктов 2, 7, 8 правил описания отклонений.

Поделиться темой: